package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a href="(\/string1\/)(.*?)(\/string2)">`)
var str = `<a href="/string1/any string here/string2">text here</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}