re = /(?:"[^"]*"[^"]*)*?\"{1}([^"]*?([']{1,})[^"]*?)\"/
str = 'If you place a quote there: () it should not be detected, but if "you place a quote there: (()) " it should be detected , apparently if there is no quote between double-quotes elsewhere and there are some outside double-quotes ex: () those outside are detected and we do not want that.
My problem is that I want to match single quotes using a regex, but I only want to do so if they are being quotes : between double-quotes, like so : "(())" add/remove single quotes between parenthesis to test...
(()) = should match
() = should not match'
# Print the match result
str.match(re) do |match|
puts match.to_s
end