const regex = new RegExp('"([^"\\\\]*(\\\\(.|\\n)[^"\\\\]*)*)"[\\s]*=[\\s]*"([^"\\\\]*(\\\\(.|\\n)[^"\\\\]*)*)"[\\s]*;', 'g')
const str = `"quickAudioRecord_recordButtonPressedLabel" = "放开来发送";
"quickAudioRecord_layoutViewSlideToCancel" = "向上滑动取消";
"quickAudioRecord_releaseToCancel" = "放开取消" ;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}