package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[\wçğıİöşü]+\b`)
var str = `Behiç Güneş`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}