import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>\\s*(https?://(?:www\\.)?youtu(?:.be|be.com)+/(?:watch/?\\?v=|v/)?([^\\s&<\\'\"]+))(&[-_,.=&;a-zA-Z0-9]*)?.*?</p>";
final String string = "<p>https://youtu.be/LBY12usmYAA</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}