re = /<p>\s*(https?:\/\/(?:www\.)?youtu(?:.be|be.com)+\/(?:watch\/?\?v=|v\/)?([^\s&<\'"]+))(&[-_,.=&;a-zA-Z0-9]*)?.*?<\/p>/
str = '<p>https://youtu.be/LBY12usmYAA</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end