package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`product_default_shipping_cost:\['(.*?)'\]`)
var str = `product_sale_price:['19.99'], product_default_shipping_cost:['1.99'], product_type:['Newegg']`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}