// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"product_default_shipping_cost:\['(.*?)'\]").unwrap();
let string = "product_sale_price:['19.99'], product_default_shipping_cost:['1.99'], product_type:['Newegg']";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}