import Foundation
let pattern = #"(?<!^)(?=\D)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"A1B22C333"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)