#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "refs\/tags\/(\d+\.\d+\.\d+[-.]?[\w]*)"
Local $sString = "refs/tags/0.0.1-alpha" & @CRLF & _
"refs/tags/0.0.1-alpha1" & @CRLF & _
"refs/tags/140.02.1-FINAL" & @CRLF & _
"refs/tags/1.2.3" & @CRLF & _
"refs/tags/1.2.3000000.FINAL" & @CRLF & _
"refs/tags/1.0002.3..FINAL" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")