using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"refs\/tags\/(\d+\.\d+\.\d+[-.]?[\w]*)";
string input = @"refs/tags/0.0.1-alpha
refs/tags/0.0.1-alpha1
refs/tags/140.02.1-FINAL
refs/tags/1.2.3
refs/tags/1.2.3000000.FINAL
refs/tags/1.0002.3..FINAL
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}