package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`refs\/tags\/(\d+\.\d+\.\d+[-.]?[\w]*)`)
var str = `refs/tags/0.0.1-alpha
refs/tags/0.0.1-alpha1
refs/tags/140.02.1-FINAL
refs/tags/1.2.3
refs/tags/1.2.3000000.FINAL
refs/tags/1.0002.3..FINAL
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}