use strict;
my $str = 'refs/tags/0.0.1-alpha
refs/tags/0.0.1-alpha1
refs/tags/140.02.1-FINAL
refs/tags/1.2.3
refs/tags/1.2.3000000.FINAL
refs/tags/1.0002.3..FINAL
';
my $regex = qr/refs\/tags\/(\d+\.\d+\.\d+[-.]?[\w]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}