#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:((?:\+|00)(?:33|33\s0))|0)\s*[1-9](?:[ ]\d{2}){4}" & @CRLF & _
""
Local $sString = "06 01 02 03 04" & @CRLF & _
"+33 6 01 02 03 04" & @CRLF & _
"0033 7 01 02 03 04" & @CRLF & _
"06 01 02 03 04" & @CRLF & _
"+33 6 01 02 03 04" & @CRLF & _
"0033 6 01 02 03 04" & @CRLF & _
"+33 06 01 02 03 04" & @CRLF & _
"0033 06 01 02 03 04" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")