using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:((?:\+|00)(?:33|33\s0))|0)\s*[1-9](?:[ ]\d{2}){4}
";
string input = @"06 01 02 03 04
+33 6 01 02 03 04
0033 7 01 02 03 04
06 01 02 03 04
+33 6 01 02 03 04
0033 6 01 02 03 04
+33 06 01 02 03 04
0033 06 01 02 03 04
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}