// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:((?:\+|00)(?:33|33\s0))|0)\s*[1-9](?:[ ]\d{2}){4}
").unwrap();
let string = "06 01 02 03 04
+33 6 01 02 03 04
0033 7 01 02 03 04
06 01 02 03 04
+33 6 01 02 03 04
0033 6 01 02 03 04
+33 06 01 02 03 04
0033 06 01 02 03 04
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}