#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d*\.?\d+)(?:\(g\/\d*ml\)|g?\b)"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"0.1" & @CRLF & _
".1" & @CRLF & _
"1g" & @CRLF & _
"0.1g" & @CRLF & _
".1g" & @CRLF & _
"1(g/100ml)" & @CRLF & _
".1(g/ml)" & @CRLF & _
"" & @CRLF & _
"1abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")