import Foundation
let pattern = #"<([^\/> ]+)\s*([^>]*)\s*(?:\/>|>(.*)<\/\1>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<tag attrib="text" attrib2 = "othertext"><innertag>value</innertag></tag>
<tag2 />
<tag3/>
<tag4>value</tag4>
<tag5></tag5>
<tag2 attrib="text" attrib2 = "othertext" />
<tag3 attrib="text" attrib2 = "othertext"/>
<tag5 attrib="text" attrib2 = "othertext"></tag5>
<([^\/> ]+)\s*([^>]*)\s*(?:\/>|>(.*)<\/\1>) (with global) finds all tags in scope
1st group is tagname
2nd group is attributes
3rd group (if it exists) is value of the tag
Apply pattern again on 3th group to find internal tags (recurse in the code to parse entire xml!)
Apply pattern below on 2nd group to find all attributes:
\s+([^<>\=" ]+)\s*=\s*"([^"]*)" (with global) finds attributes
1st group is attributename
2nd group is attributevalue
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)