$re = '/.*park(*SKIP)(*FAIL)|.*dog/';
$str = 'That park has too many dogs';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);