const regex = new RegExp('x.*z', 'm')
const str = `xaz xazx xaxsza zsxdaszdx zasxz xaaz xaaaz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}