use strict;
my $str = '<table style="width:100%">
<tr>
<th>FirstName</th>
<th>LastName</th>
<th>Age</th>
</tr>
<tr>
<td>Jill</td>
<td>Nigam</td>
<td>25</td>
</tr>
<tr>
<td>PRanoy</td>
<td>Dewanjee</td>
<td>30</td>
</tr>
</table>';
my $regex = qr/(?x)
(?<=<td>)[^<>]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}