$re = '/[\{uD83C}-\x{DBFF}\x{DC00}-\x{DFFF}]+/m';
$str = 'This is 😛 a test with 🙌 emojis in the 🐦 string
';
$subst = "<i>$0</i>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;