$re = '/([a-z0-9,!#\$%&\*\+=\?\^_`\{\|}~-]+(\.[a-z0-9,!#\$%&\*\+=\?\^_`\{\|}~-]+)*@[a-z0-9-]+(\.[a-z0-9-]+)*\.(?>[a-z]{2,})[ ]?):(.*)/m';
$str = 'test@test.ru:123
test@test.ru:1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);