package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Za-z!#\$%&'\*\+\-\/=\?\^_`{\|}~åäöÅÄÖ]+[A-Za-z!#\$%&'\*\+\-\/=\?\^_`{\|}~åäöÅÄÖ\.]*[A-Za-z!#\$%&'\*\+\-\/=\?\^_`{\|}~åäöÅÄÖ]+@[A-Za-zÅÄÖåäö]+\.[A-Za-z]*$`)
var str = `ivar.matstoms@gmail.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}