const regex = /hsoub_adplace = (\w*);/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('hsoub_adplace = (\\w*);', 'gmi')
const str = `<script type="text/javascript"><!--
hsoub_adplace = XXXXXXXXXXXXXXX;
hsoub_adplace_size = 'XXXxXXX';
//--></script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}