$re = '/([A-Z]?[a-z ]+) (.*)/m';
$str = 'Pump sectional CNS-300-400
Electric motor AC-600 №130
Switching vacuum breaker 1 BM-600 3000
Transformator TMG-CAT-340-748';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);