const regex = /(?<=_V1_)(.+?)(?=.jpg)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=_V1_)(.+?)(?=.jpg)', '')
const str = `https://m.media-amazon.com/images/M/MV5BYWNlMWMxOWYtZWI0Mi00ZTg0LWEwZTMtZTEzZDY0NzAxYTA4XkEyXkFqcGdeQXVyMTQxNzMzNDI@._V1_UX182_CR0,0,182,268_AL_.jpg`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);