#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([0-9\.]+)\$\^\{\*{1,3}\}\$"
Local $sString = "0.047$^{***}$"
Local $sSubst = "\\textbf{$1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)