using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9\.]+)\$\^\{\*{1,3}\}\$";
string substitution = @"\\textbf{$1}";
string input = @"0.047$^{***}$";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}