import Foundation
let pattern = #"([0-9\.]+)\$\^\{\*{1,3}\}\$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"0.047$^{***}$"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\textbf{$1}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)