# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^()]+)\(([^()]*)\)"
test_str = ("ABC1.1(1) 拆分为ABC1.1和1 两部分\n"
"%DEF2.1(3) 拆分为%DEF2.1和3 两部分\n"
"@ I/O GHI3.3(5) 拆分为@ I/O GHI3.3 和5 两部分\n\n"
"ABC1.1(1) \n"
"%DEF2.1(3) \n"
"@ I/O GHI3.3(5) ")
subst = "$1 $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.