#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(.*?\*){2,}|.*? |\*$).*?\*.*$"
Local $sString = "test*" & @CRLF & _
"*_test" & @CRLF & _
"test*something" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"*" & @CRLF & _
"test_**" & @CRLF & _
"**_test" & @CRLF & _
"test*something*" & @CRLF & _
"test *something" & @CRLF & _
"test *"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")