package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b([1-9]|[12][0-9]|3[01])-(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)-(\d{2})\b`)
var str = `3-Jul-16
30-Jun-16`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}