$re = '/\((\w+)\)\((\d+)\)\((\w+)\)(\((\w+)\))?/';
$str = '(name)(1)(percent)(who)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);