$re = '/^-?(\d|(\d+,?\d+))*(\.\d+)?(e\d+)?$/';
$str = '555,44.0e0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);