#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^ # Start of the string (or line with m/multiline flag) " & @CRLF & _
"(?=.*\d) # Lookahead that checks for at least one digit in the match" & @CRLF & _
"\+? # An optional literal plus '+'" & @CRLF & _
"[#*\d]{1,15} # one to fifteen of literal '#' or '*' or digit (\d is [0-9])" & @CRLF & _
"$ # End of the string (line with m/multiline flag)"
Local $sString = "+1234" & @CRLF & _
"445678999" & @CRLF & _
"+#7897897" & @CRLF & _
"+345764756#775" & @CRLF & _
"+#" & @CRLF & _
"+*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")