use strict;
my $str = '15HGH
12ABCD
ABCD(Whatever)(test)
15HGH(Whatever)ASD';
my $regex = qr/(\d+|\w|\([^)]++\))/mp;
my $subst = '\\1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";