package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]+(\.[0-9]+)?)`)
var str = `123.345
123.345.654
123.42353453
1243453
346546.645654654654`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}