# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/href="x-msg:\\/\\/\d+\\/"/href="#"/;t' <<< "<base href=\"x-msg://1726/\">"