re = /\{\[.+?\]\}/m
str = 'data = ABSIFHIEHFINE -2938 NODFNJN {[somedate]} oiejfoen'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end