import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*) \\(";
final String string = "Artist - Title (12\") (Warner Bros - WB1210)\n"
+ "Artist - Title (12\", Promo) (Warner Bros - WB1212)\n"
+ "Artist - Title (Summer Mix) (12\", Promo) (Warner Bros - WB1444)\n"
+ "Artist - Title (12\", LP Album) (Warner Bros- - WB9449)\n"
+ "Artist - Title (12\", Red) (Warner Bros - WB1211)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}