$re = '/^(?!.*Drive).*EFI.*$/m';
$str = 'EFI Internal Shell
EFI Hard Drive
EFI Drive';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);