import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(#Macro(.|[\\r\\n])+?#EndMacro)";
final String string = " #Macro\n"
+ " #object\n"
+ " value=1\n"
+ " value=2\n"
+ " #EndMacroEnt\n"
+ " #object\n"
+ " value=5\n"
+ " value=6\n"
+ " #EndMacroEnt\n"
+ " #EndMacro";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}