$re = '/(?:\.)(VFI?|FR|ENGLISH|EN|SPANISH|SPA)(?:\.|$)/i';
$str = 'Virgin..Suicides..vfi..vf..1999..1080p..FR..EN..X264..AC3-mHDgz-www..Zone-Telechargement..com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);