using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((-?(\d{1,3})(\.\d+)?) (-?(\d{1,3})(\.\d+)?)),\s*){3,}$";
string input = @"41.278198 95.914285,
41.278198 -95.914285,
41.278198 -95.914285,";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}