$re = '/\bz.p\b/im';
$str = 'Write a sentence with no zip and zap spaces:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);