package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^ *while +\( *([a-zA-Z][a-zA-Z0-9_]*) *([=<>]) *([a-zA-Z][a-zA-Z0-9_]*|[0-9]+) *\) *$`)
var str = `while ( b = 4 )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}