re = /^ *while +\( *([a-zA-Z][a-zA-Z0-9_]*) *([=<>]) *([a-zA-Z][a-zA-Z0-9_]*|[0-9]+) *\) *$/
str = 'while ( b = 4 )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end