#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?<!\w)(?:http://www\.example\.com)?/(\S+?)\.pdf\b"
Local $sString = "some containing string http://www.example.com/subfolder/name.pdf or /subfolder/name.pdf" & @CRLF & _
"" & @CRLF & _
"<a href="/pdf/subdir/name.pdf">clickhere</a><a href="/pdf/subdir/name.pdf">2nd PDF</a>"
Local $sSubst = "/wp-content/uploads/old/$1.pdf"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)