using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\w)(?:http://www\.example\.com)?/(\S+?)\.pdf\b";
string substitution = @"/wp-content/uploads/old/$1.pdf";
string input = @"some containing string http://www.example.com/subfolder/name.pdf or /subfolder/name.pdf
<a href=""/pdf/subdir/name.pdf"">clickhere</a><a href=""/pdf/subdir/name.pdf"">2nd PDF</a>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}